summaryrefslogtreecommitdiff
path: root/media-libs/oneVPL-cpu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
commitd479c9c5c724c7b1300a98e44975f31f4f2e51dd (patch)
treec2f5550bfe03e1b3f19014e1576dcf50e6bd818c /media-libs/oneVPL-cpu/files
parentee8ad1509f726e8fa598472117e5bbffd241ebab (diff)
gentoo auto-resync : 06:12:2022 - 21:11:24
Diffstat (limited to 'media-libs/oneVPL-cpu/files')
-rw-r--r--media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-respect-user-flags.patch13
-rw-r--r--media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-use-system-libs.patch49
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-respect-user-flags.patch b/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-respect-user-flags.patch
new file mode 100644
index 000000000000..59aad21af7f3
--- /dev/null
+++ b/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-respect-user-flags.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 981574e..7bdf346 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -72,8 +72,6 @@ set(CMAKE_POSITION_INDEPENDENT_CODE true)
+ # Keep executable bits on shared objects when installing regardless of distro
+ set(CMAKE_INSTALL_SO_NO_EXE 0)
+
+-include(cmake/CompileOptions.cmake)
+-
+ if(NOT BUILD_GPL_X264)
+ if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ set(BUILD_OPENH264 ON)
diff --git a/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-use-system-libs.patch b/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-use-system-libs.patch
new file mode 100644
index 000000000000..aa9363a65e83
--- /dev/null
+++ b/media-libs/oneVPL-cpu/files/oneVPL-cpu-2022.2.5-use-system-libs.patch
@@ -0,0 +1,49 @@
+diff --git a/cpu/ext/ffmpeg-codecs/CMakeLists.txt b/cpu/ext/ffmpeg-codecs/CMakeLists.txt
+index 7bde28b..c8067c4 100644
+--- a/cpu/ext/ffmpeg-codecs/CMakeLists.txt
++++ b/cpu/ext/ffmpeg-codecs/CMakeLists.txt
+@@ -38,9 +38,9 @@ endif()
+
+ # Set basic FFmpeg and codec libs
+ if("${CMAKE_SIZEOF_VOID_P}" STREQUAL "8")
+- set(SVTHEVCENC_LIB ${VPL_DEP_DIR}/lib/libSvtHevcEnc.a)
+- set(SVTAV1ENC_LIB ${VPL_DEP_DIR}/lib/libSvtAv1Enc.a)
+- set(DAV1D_LIB ${VPL_DEP_DIR}/lib/libdav1d.a)
++ set(SVTHEVCENC_LIB ${VPL_DEP_DIR}/lib64/libSvtHevcEnc.so)
++ set(SVTAV1ENC_LIB ${VPL_DEP_DIR}/lib64/libSvtAv1Enc.so)
++ set(DAV1D_LIB ${VPL_DEP_DIR}/lib64/libdav1d.so)
+
+ if(NOT EXISTS ${SVTHEVCENC_LIB}
+ OR NOT EXISTS ${SVTAV1ENC_LIB}
+@@ -49,10 +49,10 @@ if("${CMAKE_SIZEOF_VOID_P}" STREQUAL "8")
+ endif()
+ endif()
+
+-set(AVCODEC_LIB ${VPL_DEP_DIR}/lib/libavcodec.a)
+-set(AVUTIL_LIB ${VPL_DEP_DIR}/lib/libavutil.a)
+-set(AVFILTER_LIB ${VPL_DEP_DIR}/lib/libavfilter.a)
+-set(SWSCALE_LIB ${VPL_DEP_DIR}/lib/libswscale.a)
++set(AVCODEC_LIB ${VPL_DEP_DIR}/lib64/libavcodec.so)
++set(AVUTIL_LIB ${VPL_DEP_DIR}/lib64/libavutil.so)
++set(AVFILTER_LIB ${VPL_DEP_DIR}/lib64/libavfilter.so)
++set(SWSCALE_LIB ${VPL_DEP_DIR}/lib64/libswscale.so)
+
+ if(NOT EXISTS ${AVCODEC_LIB}
+ OR NOT EXISTS ${AVUTIL_LIB}
+@@ -135,14 +135,14 @@ endif()
+
+ # Set AVC encoder lib name
+ if(BUILD_GPL_X264)
+- set(H264_ENC_LIB ${VPL_DEP_DIR}/lib/libx264.a)
++ set(H264_ENC_LIB ${VPL_DEP_DIR}/lib64/libx264.so)
+ if(NOT EXISTS ${H264_ENC_LIB})
+ message(FATAL_ERROR "Could not find x264 libraries")
+ else()
+ message(STATUS "Building with GPL x264 for AVC implementation")
+ endif()
+ elseif(BUILD_OPENH264)
+- set(H264_ENC_LIB ${VPL_DEP_DIR}/lib/libopenh264.a)
++ set(H264_ENC_LIB ${VPL_DEP_DIR}/lib64/libopenh264.so)
+ if(NOT EXISTS ${H264_ENC_LIB})
+ message(FATAL_ERROR "Could not find openh264 libraries")
+ else()