summaryrefslogtreecommitdiff
path: root/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild')
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
new file mode 100644
index 000000000000..4a07225533b4
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}