summaryrefslogtreecommitdiff
path: root/media-libs/mpvqt/mpvqt-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 19:30:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 19:30:41 +0000
commit026061ba423025e6713112920f290759cdee03c4 (patch)
tree0e557363849e4d5c1320820fcf175bc1ec9690ab /media-libs/mpvqt/mpvqt-1.0.0.ebuild
parent479921825a5c44a5fbcd5441f00ee98e54db9bac (diff)
gentoo auto-resync : 25:12:2023 - 19:30:41
Diffstat (limited to 'media-libs/mpvqt/mpvqt-1.0.0.ebuild')
-rw-r--r--media-libs/mpvqt/mpvqt-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/mpvqt/mpvqt-1.0.0.ebuild b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
new file mode 100644
index 000000000000..990a449f34e3
--- /dev/null
+++ b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.245.0
+QTMIN=6.5.0
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="libmpv wrapper for QtQuick2 and QML"
+HOMEPAGE="https://invent.kde.org/libraries/mpvqt"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-3 LGPL-2.1 ) CC-BY-SA-4.0 MIT BSD"
+SLOT="6"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,opengl]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ media-video/mpv:=[libmpv]
+"
+RDEPEND="${DEPEND}"