summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-libs/mesa/mesa-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 03083871b14d..ff719014070b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit llvm meson multilib-minimal python-any-r1
+inherit llvm meson multilib-minimal python-any-r1 linux-info
OPENGL_DIR="xorg-x11"
@@ -334,6 +334,15 @@ pkg_setup() {
ewarn "detected! This can cause problems. For details, see bug 459306."
fi
+ # os_same_file_description requires the kcmp syscall,
+ # which is only available with CONFIG_CHECKPOINT_RESTORE=y.
+ # Currently only AMDGPU utilizes this function, so only AMDGPU users would
+ # get a spooky warning message if the syscall fails.
+ if use gallium && use video_cards_radeonsi; then
+ CONFIG_CHECK="~CHECKPOINT_RESTORE"
+ linux-info_pkg_setup
+ fi
+
if use gallium && use llvm; then
llvm_pkg_setup
fi