summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-libs/mesa/mesa-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 7e2bd851871f..1da56517de7e 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit llvm meson multilib-minimal python-any-r1 linux-info
@@ -74,7 +74,6 @@ REQUIRED_USE="
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.100"
RDEPEND="
- !app-eselect/eselect-mesa
>=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
>=media-libs/libglvnd-1.3.2[X?,${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8[${MULTILIB_USEDEP}]
@@ -143,9 +142,10 @@ RDEPEND="${RDEPEND}
# 1. List all the working slots (with min versions) in ||, newest first.
# 2. Update the := to specify *max* version, e.g. < 10.
# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_MAX_SLOT="10"
+LLVM_MAX_SLOT="11"
LLVM_DEPSTR="
|| (
+ sys-devel/llvm:11[${MULTILIB_USEDEP}]
sys-devel/llvm:10[${MULTILIB_USEDEP}]
sys-devel/llvm:9[${MULTILIB_USEDEP}]
)
@@ -258,8 +258,9 @@ pkg_pretend() {
if use vulkan; then
if ! use video_cards_i965 &&
! use video_cards_iris &&
- ! use video_cards_radeonsi; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, or radeonsi"
+ ! use video_cards_radeonsi &&
+ ! use video_cards_v3d; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, radeonsi, or v3d"
fi
fi
@@ -472,6 +473,7 @@ multilib_src_configure() {
vulkan_enable video_cards_i965 intel
vulkan_enable video_cards_iris intel
vulkan_enable video_cards_radeonsi amd
+ vulkan_enable video_cards_v3d broadcom
fi
if use gallium; then
@@ -524,7 +526,7 @@ multilib_src_install_all() {
}
multilib_src_test() {
- meson test -v -C "${BUILD_DIR}" -t 100
+ meson_src_test -t 100
}
# $1 - VIDEO_CARDS flag (check skipped for "--")