summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
commitd56d144655e3785864da43c9acb6c228ef9360ae (patch)
treeb769b599a558483f82e9a057c41f1edd29626dd1 /media-libs/mesa/mesa-9999.ebuild
parentfab849d1daed0ba7f2ac497d07985c3dbb692543 (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 20146f77c705..d1efde2b6aa7 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
@@ -209,6 +209,11 @@ RDEPEND="${RDEPEND}
unset {LLVM,CLANG}_DEPSTR{,_AMDGPU}
DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-base/xorg-proto
+"
+BDEPEND="
${PYTHON_DEPS}
opencl? (
>=sys-devel/gcc-4.6
@@ -217,9 +222,6 @@ DEPEND="${RDEPEND}
sys-devel/flex
sys-devel/gettext
virtual/pkgconfig
- valgrind? ( dev-util/valgrind )
- x11-base/xorg-proto
- x11-libs/libXrandr[${MULTILIB_USEDEP}]
$(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
"
@@ -307,7 +309,7 @@ pkg_pretend() {
}
python_check_deps() {
- has_version --host-root ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
+ has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
}
pkg_setup() {