summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-libs/mesa/mesa-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 5829adce48f2..d200a650255d 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -33,18 +33,15 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic cpu_flags_x86_sse2 d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
+ +classic cpu_flags_x86_sse2 d3d9 debug +gallium gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
- d3d9? ( || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
- gles1? ( egl )
- gles2? ( egl )
+ d3d9? ( gallium || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
osmesa? ( gallium )
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
- wayland? ( egl gbm )
video_cards_crocus? ( gallium )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
@@ -64,14 +61,14 @@ REQUIRED_USE="
video_cards_v3d? ( gallium )
video_cards_vc4? ( gallium )
video_cards_virgl? ( gallium )
- video_cards_vivante? ( gallium gbm )
+ video_cards_vivante? ( gallium )
video_cards_vmware? ( gallium )
xa? ( X )
xvmc? ( X )
zink? ( gallium vulkan )
"
-LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.107"
+LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.109"
RDEPEND="
>=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
>=media-libs/libglvnd-1.3.2[X?,${MULTILIB_USEDEP}]
@@ -104,7 +101,6 @@ RDEPEND="
selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
wayland? (
>=dev-libs/wayland-1.18.0:=[${MULTILIB_USEDEP}]
- >=dev-libs/wayland-protocols-1.8
)
${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
video_cards_intel? (
@@ -210,6 +206,7 @@ unset {LLVM,CLANG}_DEPSTR{,_AMDGPU}
DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )
+ wayland? ( >=dev-libs/wayland-protocols-1.24 )
X? (
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-base/xorg-proto
@@ -384,12 +381,6 @@ multilib_src_configure() {
use wayland && platforms+=",wayland"
emesonargs+=(-Dplatforms=${platforms#,})
- if use X || use egl; then
- emesonargs+=(-Dglvnd=true)
- else
- emesonargs+=(-Dglvnd=false)
- fi
-
if use gallium; then
emesonargs+=(
$(meson_feature llvm)
@@ -512,8 +503,9 @@ multilib_src_configure() {
-Dglx=$(usex X dri disabled)
-Dshared-glapi=enabled
-Ddri3=enabled
- $(meson_feature egl)
- $(meson_feature gbm)
+ -Degl=true
+ -Dgbm=true
+ -Dglvnd=true
$(meson_feature gles1)
$(meson_feature gles2)
$(meson_use osmesa)