summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-24.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-06 00:07:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-06 00:07:58 +0100
commit44cec61076bf2bbb3cea1fc89943dd6818a5acc5 (patch)
tree68f1cddcf97a0d746c1e9c186171b7bd603efccf /media-libs/mesa/mesa-24.1.0.ebuild
parent9d1e33edaf09cde926d589461f40e378d4124be9 (diff)
gentoo auto-resync : 06:06:2024 - 00:07:57
Diffstat (limited to 'media-libs/mesa/mesa-24.1.0.ebuild')
-rw-r--r--media-libs/mesa/mesa-24.1.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-24.1.0.ebuild b/media-libs/mesa/mesa-24.1.0.ebuild
index f9c4e1acfcbb..74f5ca28a2f6 100644
--- a/media-libs/mesa/mesa-24.1.0.ebuild
+++ b/media-libs/mesa/mesa-24.1.0.ebuild
@@ -157,7 +157,10 @@ BDEPEND="
app-alternatives/yacc
app-alternatives/lex
virtual/pkgconfig
- $(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
+ $(python_gen_any_dep "
+ >=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]
+ dev-python/packaging[\${PYTHON_USEDEP}]
+ ")
video_cards_intel? (
~dev-util/intel_clc-${PV}
dev-libs/libclc[spirv(-)]
@@ -236,7 +239,8 @@ pkg_pretend() {
}
python_check_deps() {
- python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]" || return 1
+ python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/packaging[${PYTHON_USEDEP}]" || return 1
if use llvm && use vulkan && use video_cards_intel && use amd64; then
python_has_version -b "dev-python/ply[${PYTHON_USEDEP}]" || return 1
fi