summaryrefslogtreecommitdiff
path: root/media-libs/mediastreamer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /media-libs/mediastreamer/files
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'media-libs/mediastreamer/files')
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.8.2-autopoint.patch17
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch59
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.8.2-libav9.patch115
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.8.2-v4l-automagic.patch54
4 files changed, 0 insertions, 245 deletions
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.8.2-autopoint.patch b/media-libs/mediastreamer/files/mediastreamer-2.8.2-autopoint.patch
deleted file mode 100644
index 5704234af060..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.8.2-autopoint.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- mediastreamer-2.8.2/configure.ac.orig 2012-06-01 16:31:34.000000000 +0400
-+++ mediastreamer-2.8.2/configure.ac 2012-06-01 16:36:08.586809086 +0400
-@@ -191,13 +191,13 @@
- if test "$mingw_found" != "yes" ; then
- dnl gettext macro does not work properly under mingw. And we want to use the one provided by GTK.
- AM_GNU_GETTEXT([external])
-- AM_GNU_GETTEXT_VERSION([0.18])
- LIBS="$LIBS $LIBINTL"
- else
- AC_DEFINE(ENABLE_NLS,1,[Tells whether localisation is possible])
- AC_DEFINE(HAVE_GETTEXT,1,[Tells wheter localisation is possible])
- LIBS="$LIBS -lintl"
- fi
-+AM_GNU_GETTEXT_VERSION([0.18])
-
- AM_CONDITIONAL(BUILD_MACOSX, test x$macosx_found = xyes)
- AM_CONDITIONAL(BUILD_IOS, test x$ios_found = xyes)
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch b/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch
deleted file mode 100644
index 293e6e78dcab..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.8.2-ffmpeg-1.0.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=445168
-
-commit f586917ea4d66f9ba8910f0967a8830e54d50784
-Author: Yann Diorcet <yann.diorcet@belledonne-communications.com>
-Date: Tue Jun 5 11:07:48 2012 +0200
-
- Fixes for new versions of ffmpeg
-
-diff --git a/src/h264dec.c b/src/h264dec.c
-index c4a84ee..5229b5e 100644
---- a/src/h264dec.c
-+++ b/src/h264dec.c
-@@ -45,7 +45,9 @@ typedef struct _DecData{
- static void ffmpeg_init(){
- static bool_t done=FALSE;
- if (!done){
-+#ifdef FF_API_AVCODEC_INIT
- avcodec_init();
-+#endif
- avcodec_register_all();
- done=TRUE;
- }
-diff --git a/src/videoenc.c b/src/videoenc.c
-index 21d016f..fb35760 100644
---- a/src/videoenc.c
-+++ b/src/videoenc.c
-@@ -39,6 +39,10 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
- static bool_t avcodec_initialized=FALSE;
-
-+#ifndef FF_I_TYPE
-+#define FF_I_TYPE AV_PICTURE_TYPE_I
-+#endif
-+
- #ifdef ENABLE_LOG_FFMPEG
-
- void ms_ffmpeg_log_callback(void* ptr, int level, const char* fmt, va_list vl)
-@@ -53,7 +57,9 @@ void ms_ffmpeg_log_callback(void* ptr, int level, const char* fmt, va_list vl)
-
- void ms_ffmpeg_check_init(){
- if(!avcodec_initialized){
-+#ifdef FF_API_AVCODEC_INIT
- avcodec_init();
-+#endif
- avcodec_register_all();
- avcodec_initialized=TRUE;
- #ifdef ENABLE_LOG_FFMPEG
-@@ -300,10 +306,10 @@ static void prepare_h263(EncState *s){
- if (s->profile==0){
- s->codec=CODEC_ID_H263;
- }else{
-+ /*
- c->flags|=CODEC_FLAG_H263P_UMV;
- c->flags|=CODEC_FLAG_AC_PRED;
- c->flags|=CODEC_FLAG_H263P_SLICE_STRUCT;
-- /*
- c->flags|=CODEC_FLAG_OBMC;
- c->flags|=CODEC_FLAG_AC_PRED;
- */
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.8.2-libav9.patch b/media-libs/mediastreamer/files/mediastreamer-2.8.2-libav9.patch
deleted file mode 100644
index 0b335e282cfd..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.8.2-libav9.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-diff -urb mediastreamer-2.8.2.old/src/h264dec.c mediastreamer-2.8.2/src/h264dec.c
---- mediastreamer-2.8.2.old/src/h264dec.c 2013-06-22 19:13:24.649838347 +0200
-+++ mediastreamer-2.8.2/src/h264dec.c 2013-06-22 19:20:52.044822431 +0200
-@@ -55,10 +55,10 @@
- int error;
- codec=avcodec_find_decoder(CODEC_ID_H264);
- if (codec==NULL) ms_fatal("Could not find H264 decoder in ffmpeg.");
-- avcodec_get_context_defaults(&d->av_context);
-- error=avcodec_open(&d->av_context,codec);
-+ avcodec_get_context_defaults3(&d->av_context, NULL);
-+ error=avcodec_open2(&d->av_context,codec, NULL);
- if (error!=0){
-- ms_fatal("avcodec_open() failed.");
-+ ms_fatal("avcodec_open2() failed.");
- }
- }
-
-diff -urb mediastreamer-2.8.2.old/src/jpegwriter.c mediastreamer-2.8.2/src/jpegwriter.c
---- mediastreamer-2.8.2.old/src/jpegwriter.c 2013-06-22 19:13:24.649838347 +0200
-+++ mediastreamer-2.8.2/src/jpegwriter.c 2013-06-22 19:17:57.087828655 +0200
-@@ -90,7 +90,7 @@
- mblk_t *jpegm;
- struct SwsContext *sws_ctx;
-
-- AVCodecContext *avctx=avcodec_alloc_context();
-+ AVCodecContext *avctx=avcodec_alloc_context3(NULL);
-
- avctx->width=yuvbuf.w;
- avctx->height=yuvbuf.h;
-@@ -98,9 +98,9 @@
- avctx->time_base.den =1;
- avctx->pix_fmt=PIX_FMT_YUVJ420P;
-
-- error=avcodec_open(avctx,s->codec);
-+ error=avcodec_open2(avctx,s->codec,NULL);
- if (error!=0) {
-- ms_error("avcodec_open() failed: %i",error);
-+ ms_error("avcodec_open2() failed: %i",error);
- cleanup(s,NULL);
- av_free(avctx);
- return;
-diff -urb mediastreamer-2.8.2.old/src/nowebcam.c mediastreamer-2.8.2/src/nowebcam.c
---- mediastreamer-2.8.2.old/src/nowebcam.c 2013-06-22 19:13:24.652838347 +0200
-+++ mediastreamer-2.8.2/src/nowebcam.c 2013-06-22 19:20:43.198822745 +0200
-@@ -68,9 +68,9 @@
- return NULL;
- }
-
-- avcodec_get_context_defaults(&av_context);
-- if (avcodec_open(&av_context,codec)<0){
-- ms_error("jpeg2yuv: avcodec_open failed");
-+ avcodec_get_context_defaults3(&av_context, NULL);
-+ if (avcodec_open2(&av_context,codec,NULL)<0){
-+ ms_error("jpeg2yuv: avcodec_open2 failed");
- return NULL;
- }
- av_init_packet(&pkt);
-diff -urb mediastreamer-2.8.2.old/src/videodec.c mediastreamer-2.8.2/src/videodec.c
---- mediastreamer-2.8.2.old/src/videodec.c 2013-06-22 19:13:24.654838347 +0200
-+++ mediastreamer-2.8.2/src/videodec.c 2013-06-22 19:28:58.436805127 +0200
-@@ -52,7 +52,7 @@
- DecState *s=(DecState *)ms_new0(DecState,1);
- ms_ffmpeg_check_init();
-
-- avcodec_get_context_defaults(&s->av_context);
-+ avcodec_get_context_defaults3(&s->av_context, NULL);
- s->av_codec=NULL;
- s->codec=cid;
- s->input=NULL;
-@@ -133,8 +133,8 @@
- if (s->av_context.codec==NULL){
- /* we must know picture size before initializing snow decoder*/
- if (s->codec!=CODEC_ID_SNOW){
-- error=avcodec_open(&s->av_context, s->av_codec);
-- if (error!=0) ms_error("avcodec_open() failed: %i",error);
-+ error=avcodec_open2(&s->av_context, s->av_codec,NULL);
-+ if (error!=0) ms_error("avcodec_open2() failed: %i",error);
- if (s->codec==CODEC_ID_MPEG4 && s->dci_size>0){
- s->av_context.extradata=s->dci;
- s->av_context.extradata_size=s->dci_size;
-@@ -223,8 +223,8 @@
- int error;
- s->av_context.width=h>>16;
- s->av_context.height=h&0xffff;
-- error=avcodec_open(&s->av_context, s->av_codec);
-- if (error!=0) ms_error("avcodec_open() failed for snow: %i",error);
-+ error=avcodec_open2(&s->av_context, s->av_codec, NULL);
-+ if (error!=0) ms_error("avcodec_open2() failed for snow: %i",error);
- else {
- s->snow_initialized=TRUE;
- ms_message("Snow decoder initialized,size=%ix%i",
-diff -urb mediastreamer-2.8.2.old/src/videoenc.c mediastreamer-2.8.2/src/videoenc.c
---- mediastreamer-2.8.2.old/src/videoenc.c 2013-06-22 19:13:24.654838347 +0200
-+++ mediastreamer-2.8.2/src/videoenc.c 2013-06-22 19:20:19.732823580 +0200
-@@ -236,7 +236,7 @@
- AVCodecContext *c=&s->av_context;
- const int max_br_vbv=128000;
-
-- avcodec_get_context_defaults(c);
-+ avcodec_get_context_defaults3(c, NULL);
- if (s->codec==CODEC_ID_MJPEG)
- {
- ms_message("Codec bitrate set to %i",c->bit_rate);
-@@ -342,9 +342,9 @@
- ms_error("could not find encoder for codec id %i",s->codec);
- return;
- }
-- error=avcodec_open(&s->av_context, s->av_codec);
-+ error=avcodec_open2(&s->av_context, s->av_codec, NULL);
- if (error!=0) {
-- ms_error("avcodec_open() failed: %i",error);
-+ ms_error("avcodec_open2() failed: %i",error);
- return;
- }
- video_starter_init(&s->starter);
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.8.2-v4l-automagic.patch b/media-libs/mediastreamer/files/mediastreamer-2.8.2-v4l-automagic.patch
deleted file mode 100644
index f35660ea8c0c..000000000000
--- a/media-libs/mediastreamer/files/mediastreamer-2.8.2-v4l-automagic.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 93362c849d4a3ba1748d033369f76e93557f1c06 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 22 Nov 2012 15:02:21 +0100
-Subject: [PATCH] Support disabling V4L support completely.
-
----
- mediastreamer-2.8.2/configure.ac | 17 ++++++++++++++---
- 1 file changed, 14 insertions(+), 3 deletions(-)
-
-diff --git a/mediastreamer-2.8.2/configure.ac b/mediastreamer-2.8.2/configure.ac
-index d5be955..86703a0 100644
---- a/mediastreamer-2.8.2/configure.ac
-+++ b/mediastreamer-2.8.2/configure.ac
-@@ -624,6 +624,16 @@ PACKAGE_DATA_DIR="$prefix/share"
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${package_prefix}/share" ,[path of data])
- AC_SUBST(PACKAGE_DATA_DIR)
-
-+AC_ARG_ENABLE(v4l,
-+ [ --disable-v4l Disable usage of v4l],
-+ [case "${enableval}" in
-+ yes) v4l=yes ;;
-+ no) v4l=no ;;
-+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-v4l) ;;
-+ esac],[v4l=yes])
-+
-+if test "$v4l" = "yes" ; then
-+
- dnl check for video4linux headers
- AC_CHECK_HEADERS(linux/videodev.h linux/videodev2.h)
- if test "${ac_cv_header_linux_videodev_h}" = "yes" ; then
-@@ -637,9 +647,6 @@ else
- found_v4l2=no
- fi
-
--AM_CONDITIONAL(BUILD_V4L1, test x$found_v4l1 = xyes )
--AM_CONDITIONAL(BUILD_V4L2, test x$found_v4l2 = xyes )
--
- AC_ARG_ENABLE(libv4l1,
- [ --disable-libv4l1 Disable usage of libv4l1, really discouraged],
- [case "${enableval}" in
-@@ -680,6 +687,10 @@ this check.
- fi
- fi
-
-+fi
-+
-+AM_CONDITIONAL(BUILD_V4L1, test x$found_v4l1 = xyes )
-+AM_CONDITIONAL(BUILD_V4L2, test x$found_v4l2 = xyes )
-
- AC_ARG_ENABLE(tests,
- [ --enable-tests Disable compilation of tests],
---
-1.8.0
-