summaryrefslogtreecommitdiff
path: root/media-libs/lv2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
commit12de738b83927a4b71c3ad067edbb6279d15b368 (patch)
tree87b2ef3927262a0aba7a923512909bdbadd71b8b /media-libs/lv2/files
parent7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (diff)
gentoo auto-resync : 09:05:2023 - 23:42:14
Diffstat (limited to 'media-libs/lv2/files')
-rw-r--r--media-libs/lv2/files/lv2-1.18.10-tests-optional.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch b/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch
new file mode 100644
index 000000000000..dca3540cf171
--- /dev/null
+++ b/media-libs/lv2/files/lv2-1.18.10-tests-optional.patch
@@ -0,0 +1,53 @@
+https://gitlab.com/lv2/lv2/-/commit/8726bffa337e6374b04d0739df2812798b2c8858
+
+From 8726bffa337e6374b04d0739df2812798b2c8858 Mon Sep 17 00:00:00 2001
+From: David Robillard <d@drobilla.net>
+Date: Sat, 19 Nov 2022 17:49:14 -0500
+Subject: [PATCH] Avoid test directory entirely if tests are disabled
+
+--- a/meson.build
++++ b/meson.build
+@@ -346,7 +346,9 @@ endif
+ subdir('util')
+
+ # Data and build tests
+-subdir('test')
++if not get_option('tests').disabled()
++ subdir('test')
++endif
+
+ if not meson.is_subproject()
+ summary('Tests', not get_option('tests').disabled(), bool_yn: true)
+--- a/test/meson.build
++++ b/test/meson.build
+@@ -122,17 +122,15 @@ test_names = [
+ ]
+
+ # Build and run tests
+-if not get_option('tests').disabled()
+- foreach test_name : test_names
+- test(
++foreach test_name : test_names
++ test(
++ test_name,
++ executable(
+ test_name,
+- executable(
+- test_name,
+- files('test_@0@.c'.format(test_name)),
+- c_args: c_suppressions,
+- dependencies: lv2_dep,
+- ),
+- suite: 'unit',
+- )
+- endforeach
+-endif
++ files('test_@0@.c'.format(test_name)),
++ c_args: c_suppressions,
++ dependencies: lv2_dep,
++ ),
++ suite: 'unit',
++ )
++endforeach
+--
+GitLab