summaryrefslogtreecommitdiff
path: root/media-libs/libxmp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
commitbc7e0dbdbd194a8c2e09f82e1a5a4ea5e1b556f4 (patch)
treecb9186c88b5cfbd6c51e4b283677075c5c6ea38e /media-libs/libxmp
parentebb07c94f800907e02d2a6b92c1bc757b2f86f49 (diff)
gentoo auto-resync : 18:03:2024 - 18:50:06
Diffstat (limited to 'media-libs/libxmp')
-rw-r--r--media-libs/libxmp/Manifest4
-rw-r--r--media-libs/libxmp/libxmp-4.6.0.ebuild28
-rw-r--r--media-libs/libxmp/libxmp-9999.ebuild9
3 files changed, 36 insertions, 5 deletions
diff --git a/media-libs/libxmp/Manifest b/media-libs/libxmp/Manifest
index b46c29acf455..d69519102842 100644
--- a/media-libs/libxmp/Manifest
+++ b/media-libs/libxmp/Manifest
@@ -1,4 +1,6 @@
DIST libxmp-4.5.0.tar.gz 652983 BLAKE2B f583c309b4c4349eec73352d16bbd9b2b20fb48be101f0cba34a3597fce903442fbc203be50f940a7e3b8f53cc1bbf6ff91236fc27c6ec70b21ec17ad71bd6fb SHA512 71a57c7fcd696267c6e2d3cc12b43fe09adce9ed83f9f130755d3b2c2b984eb52e4ae4fad115ffeb07397c7cc4886fc3c4e01cbb1f047449228f7a557760cb1a
+DIST libxmp-4.6.0.tar.gz 738532 BLAKE2B d383cb2e8c15c27e9f55954a4ae2ead6978b7e073e647ab667a2c0bb15848ff582626611b3f274ac5075bcdb7b5cfdc1a4f95d2ea76dc0ea64dab595ba8ca1b8 SHA512 d287544c9b569515f1a3fa92d8d930097b252e84f86cba5dd70e9b4460d0fa70754ece45dcc7ec314e434d821b43207d700afb12c9df80b467d73e9d029baafe
EBUILD libxmp-4.5.0.ebuild 565 BLAKE2B 9690d84e64ec0f95c9c85cec98a0ba2f4ac5fce484367f85dfbe020bc459a9f9374ba9028e6d4c0f174cf6efe4ebb1d5d03e3f6ee06cde6baef6e6cb0f892c96 SHA512 a10f2dab757743fe740951d2acf1e3e0a7da07834de471b1a4ce3069198a95a55c3958ebff62609d3d9c80622593becf7159ce42d1e108414415b73ade5d7dbd
-EBUILD libxmp-9999.ebuild 566 BLAKE2B fc0d2683466296db5d05d47f2cfe5beee6c887341ea11a268f06f53e77a1fa26dd24125cde9b03c7f99e7069a967379bff637245c6b5482827f2cba95d01c334 SHA512 6d192f19669e8668849a2809956c92174422f38f06a5c1b61a77b344aada10e4b38ac78cfa65c5ce1f4a89e55e50e204148c860bfbefb695a3ab8c72caae82e8
+EBUILD libxmp-4.6.0.ebuild 598 BLAKE2B 98fccdd8fb44870cfcedee68d7842a6f0bd3949269d9ee3c2e41c3291e82982bd63150295baf80497bc5a735761e94c54e818c48fda385e914b4b63d7369c31e SHA512 3577d3a89f47028abf3d832bc19fa45305c3e4f16806dd5034e3949d90bba8e77078c3835ba3e32ca2ddf10ee6a4e02b935ba64843fe6bc040212e24d74bfa7f
+EBUILD libxmp-9999.ebuild 588 BLAKE2B e41633e95546950e8783f1d1d9533cc2d0eb74b0438044cc21bf4cca7fdb5b9e0debba1bb5af32f45d77c3f631823e7af58557aedaf7b40fba39cf121742dd13 SHA512 20725513d17f020c3ebc28e616adb3f364df6fbfb3e947b9a3f13a047f2464834f4143a31d3d1ee75ff09a26e87e3c799ad7f5dc8643479777f72648b917c8a7
MISC metadata.xml 246 BLAKE2B 03221de27616f3f7500121e460112bd248eaee25473a1866f22ad14529545303feeac5f21cd63d996a70ef4575780fabd63f8663a54174f4df7871090f39644d SHA512 79fe8212db6969bff7497a619d4e8f6c3118b490a69eb31e73a70cc788beb03715d4a6d3bca8f1be2756137a13334e29ce90956b5498e7581c91899069bbb8e9
diff --git a/media-libs/libxmp/libxmp-4.6.0.ebuild b/media-libs/libxmp/libxmp-4.6.0.ebuild
new file mode 100644
index 000000000000..3c9163a049d7
--- /dev/null
+++ b/media-libs/libxmp/libxmp-4.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library that renders module files to PCM data"
+HOMEPAGE="https://github.com/libxmp/libxmp"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
+else
+ SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# bzip2 depacker code is 0BSD
+LICENSE="LGPL-2.1+ MIT 0BSD"
+SLOT="0"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ emake V=1
+}
diff --git a/media-libs/libxmp/libxmp-9999.ebuild b/media-libs/libxmp/libxmp-9999.ebuild
index f0deadcf7930..f6027f5b906c 100644
--- a/media-libs/libxmp/libxmp-9999.ebuild
+++ b/media-libs/libxmp/libxmp-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Library that renders module files to PCM data"
HOMEPAGE="https://github.com/libxmp/libxmp"
+
if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
@@ -12,10 +13,10 @@ else
SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE=""
+# bzip2 depacker code is 0BSD
+LICENSE="MIT 0BSD"
+SLOT="0"
src_prepare() {
default