summaryrefslogtreecommitdiff
path: root/media-libs/libxmp/libxmp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/libxmp/libxmp-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/libxmp/libxmp-9999.ebuild')
-rw-r--r--media-libs/libxmp/libxmp-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/libxmp/libxmp-9999.ebuild b/media-libs/libxmp/libxmp-9999.ebuild
new file mode 100644
index 000000000000..f0deadcf7930
--- /dev/null
+++ b/media-libs/libxmp/libxmp-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library that renders module files to PCM data"
+HOMEPAGE="https://github.com/libxmp/libxmp"
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
+else
+ SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE=""
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ emake V=1
+}