summaryrefslogtreecommitdiff
path: root/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild')
-rw-r--r--media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..44eb74149d25
--- /dev/null
+++ b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune multilib-minimal
+
+DESCRIPTION="Helper library for S3TC texture (de)compression"
+HOMEPAGE="https://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
+SRC_URI="https://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/mesa[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+RESTRICT="bindist"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ default
+
+ # libtxc_dxtn is installed as a module (plugin)
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ ewarn "Depending on where you live, you might need a valid license for s3tc"
+ ewarn "in order to be legally allowed to use the external library."
+ ewarn "Redistribution in binary form might also be problematic."
+ ewarn
+ ewarn "You have been warned. Have a nice day."
+}