summaryrefslogtreecommitdiff
path: root/media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild')
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild
new file mode 100644
index 000000000000..c95ddf7bd4b3
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic ltprune multilib-minimal
+
+MY_PN="${PN/lib}"
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/"
+SRC_URI="https://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+DEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ default
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}