summaryrefslogtreecommitdiff
path: root/media-libs/libsdl/libsdl-1.2.64.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 21:13:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 21:13:07 +0100
commit58363a659e5161822c630bb4e16459a3a838696c (patch)
treee5acafcf61378ef38d817a7989e659cdaffadf4c /media-libs/libsdl/libsdl-1.2.64.ebuild
parent246c83e768dd1efb42047de864a1e92b73de8b5c (diff)
gentoo auto-resync : 27:05:2023 - 21:13:06
Diffstat (limited to 'media-libs/libsdl/libsdl-1.2.64.ebuild')
-rw-r--r--media-libs/libsdl/libsdl-1.2.64.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.64.ebuild b/media-libs/libsdl/libsdl-1.2.64.ebuild
new file mode 100644
index 000000000000..1913257ab9b7
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.64.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Simple Direct Media Layer 1.2 compatibility wrapper around SDL2"
+HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
+SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv"
+
+# IUSE dropped from real SDL1: aalib custom-cflags dga fbcon libcaca nas oss pulseaudio static-libs tslib xinerama xv
+IUSE="alsa +joystick opengl +sound test +video X"
+REQUIRED_USE="test? ( joystick opengl sound video )"
+
+# The tests are more like example programs.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/libsdl2[${MULTILIB_USEDEP},alsa=,joystick=,opengl=,sound=,video=,X=]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/opengl[${MULTILIB_USEDEP}] )
+"
+
+S="${WORKDIR}/sdl12-compat-release-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSDL12TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}