summaryrefslogtreecommitdiff
path: root/media-libs/libsbsms/libsbsms-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libsbsms/libsbsms-2.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libsbsms/libsbsms-2.0.0.ebuild')
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libsbsms/libsbsms-2.0.0.ebuild b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
new file mode 100644
index 000000000000..d29fc3b908d3
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="http://sbsms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}