summaryrefslogtreecommitdiff
path: root/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libquvi/libquvi-0.4.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libquvi/libquvi-0.4.1-r1.ebuild')
-rw-r--r--media-libs/libquvi/libquvi-0.4.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libquvi/libquvi-0.4.1-r1.ebuild b/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..a9b539cb93a0
--- /dev/null
+++ b/media-libs/libquvi/libquvi-0.4.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Library for parsing video download links"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0.4"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples static-libs"
+
+RDEPEND=">=net-misc/curl-7.18.2
+ !<media-libs/quvi-0.4.0
+ >=media-libs/libquvi-scripts-0.4.0:0.4
+ >=dev-lang/lua-5.1[deprecated]
+ !=media-libs/libquvi-0.4*:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ --without-manual
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+}