summaryrefslogtreecommitdiff
path: root/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild')
-rw-r--r--media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild b/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
deleted file mode 100644
index a6b424d6d4a7..000000000000
--- a/media-libs/libpostproc/libpostproc-0.8.0.20121125.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-2"
- EGIT_REPO_URI="https://github.com/dwbuiten/postproc.git"
-fi
-
-inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
-
-DESCRIPTION="Video post processing library"
-HOMEPAGE="https://github.com/dwbuiten/postproc"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else # Release
- SRC_URI="https://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.xz"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-fi
-IUSE="pic static-libs"
-
-# String for CPU features in the useflag[:configure_option] form
-# if :configure_option isn't set, it will use 'useflag' as configure option
-CPU_FEATURES="cpu_flags_x86_3dnow:amd3dnow altivec cpu_flags_x86_mmx:mmx cpu_flags_x86_mmxext:mmxext"
-for i in ${CPU_FEATURES}; do
- IUSE="${IUSE} ${i%:*}"
-done
-
-DEPEND=">=virtual/ffmpeg-0.10.2-r1"
-RDEPEND="${DEPEND}
- !<media-video/libav-0.8.2-r2
- !media-video/ffmpeg:0
-"
-
-src_configure() {
- local myconf="${EXTRA_LIBPOSTPROC_CONF}"
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
- [ "${i}" = "native" ] && i="host" # bug #273421
- myconf="${myconf} --cpu=${i}"
- break
- done
-
- if use pic ; then
- myconf="${myconf} --enable-pic"
- # disable asm code if PIC is required
- # as the provided asm decidedly is not PIC for x86.
- use x86 && myconf="${myconf} --disable-asm"
- fi
-
- # cross compile support
- if tc-is-cross-compiler ; then
- myconf="${myconf} --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"
- case ${CHOST} in
- *freebsd*)
- myconf="${myconf} --target-os=freebsd"
- ;;
- mingw32*)
- myconf="${myconf} --target-os=mingw32"
- ;;
- *linux*)
- myconf="${myconf} --target-os=linux"
- ;;
- esac
- fi
-
- cd "${S}"
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --shlibdir="${EPREFIX}/usr/$(get_libdir)" \
- --enable-shared \
- --cc="$(tc-getCC)" \
- --ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- $(use_enable static-libs static) \
- ${myconf} || die
-}