summaryrefslogtreecommitdiff
path: root/media-libs/libplacebo/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
commit1cfea2a84c51291a77ab820b6871efcff10c148d (patch)
tree924f8b07cb24ba72b3d889cf4b50bdff4d2785c0 /media-libs/libplacebo/files
parent441369caa3d11703d0349d4b9746b7ad10aa6cb2 (diff)
gentoo auto-resync : 07:11:2022 - 21:22:53
Diffstat (limited to 'media-libs/libplacebo/files')
-rw-r--r--media-libs/libplacebo/files/libplacebo-4.192.1-python-executable.patch8
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-llvm-libunwind.patch9
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch11
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch12
4 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libplacebo/files/libplacebo-4.192.1-python-executable.patch b/media-libs/libplacebo/files/libplacebo-4.192.1-python-executable.patch
new file mode 100644
index 000000000000..8fbad683e397
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-4.192.1-python-executable.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/731728
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -9,3 +9,3 @@
+ # Dependencies
+-prog_python = import('python').find_installation()
++prog_python = import('python').find_installation('python3')
+ libm = cc.find_library('m', required: false)
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-llvm-libunwind.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-llvm-libunwind.patch
new file mode 100644
index 000000000000..a1f0aaa2b806
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-llvm-libunwind.patch
@@ -0,0 +1,9 @@
+llvm-libunwind does not have cmake nor pkg-config files, not great
+but switch to cc.find for simplicity with meson feature-type options
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -1,3 +1,3 @@
+ ### Common dependencies
+-unwind = dependency('libunwind', required: get_option('unwind'))
++unwind = cc.find_library('libunwind', required: get_option('unwind'))
+ libexecinfo = cc.find_library('execinfo', required: false)
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
new file mode 100644
index 000000000000..35486262c992
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-python-executable.patch
@@ -0,0 +1,11 @@
+Upstream bundles python deps and uses same interpreter as meson,
+but we don't and need this to use the eclass' python3 instead.
+
+https://bugs.gentoo.org/731728
+--- a/meson.build
++++ b/meson.build
+@@ -323,3 +323,3 @@
+ thirdparty = meson.project_source_root()/'3rdparty'
+-python = import('python').find_installation()
++python = import('python').find_installation('python3')
+ python_env = environment()
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
new file mode 100644
index 000000000000..14ce1f6972c0
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
@@ -0,0 +1,12 @@
+OSDependent and OGLCompiler are already included in the shared libglslang,
+and glslang-1.3.231 normally does not install these with shared builds.
+--- a/src/glsl/meson.build
++++ b/src/glsl/meson.build
+@@ -21,5 +21,5 @@
+ cxx.find_library('MachineIndependent', required: false),
+- cxx.find_library('OSDependent', required: glslang_req),
++ cxx.find_library('OSDependent', required: false),
+ cxx.find_library('HLSL', required: glslang_req),
+- cxx.find_library('OGLCompiler', required: glslang_req),
++ cxx.find_library('OGLCompiler', required: false),
+ cxx.find_library('GenericCodeGen', required: false),