summaryrefslogtreecommitdiff
path: root/media-libs/libpgf/libpgf-6.12.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libpgf/libpgf-6.12.27.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libpgf/libpgf-6.12.27.ebuild')
-rw-r--r--media-libs/libpgf/libpgf-6.12.27.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/libpgf/libpgf-6.12.27.ebuild b/media-libs/libpgf/libpgf-6.12.27.ebuild
new file mode 100644
index 000000000000..4e0807e33311
--- /dev/null
+++ b/media-libs/libpgf/libpgf-6.12.27.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Library to load, handle and manipulate images in the PGF format"
+HOMEPAGE="http://www.libpgf.org/"
+SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ app-arch/unzip"
+
+src_prepare() {
+ if ! use doc; then
+ sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}