summaryrefslogtreecommitdiff
path: root/media-libs/libpagemaker/libpagemaker-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /media-libs/libpagemaker/libpagemaker-9999.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'media-libs/libpagemaker/libpagemaker-9999.ebuild')
-rw-r--r--media-libs/libpagemaker/libpagemaker-9999.ebuild38
1 files changed, 21 insertions, 17 deletions
diff --git a/media-libs/libpagemaker/libpagemaker-9999.ebuild b/media-libs/libpagemaker/libpagemaker-9999.ebuild
index ce90d99852b3..35b64943085a 100644
--- a/media-libs/libpagemaker/libpagemaker-9999.ebuild
+++ b/media-libs/libpagemaker/libpagemaker-9999.ebuild
@@ -1,44 +1,48 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
-DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug doc tools"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/librevenge
"
DEPEND="${RDEPEND}
dev-libs/boost
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
$(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}