summaryrefslogtreecommitdiff
path: root/media-libs/libopenshot/libopenshot-0.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-libs/libopenshot/libopenshot-0.2.7.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-libs/libopenshot/libopenshot-0.2.7.ebuild')
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.7.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/media-libs/libopenshot/libopenshot-0.2.7.ebuild b/media-libs/libopenshot/libopenshot-0.2.7.ebuild
index 45cad1c947ad..bd3a3381e83f 100644
--- a/media-libs/libopenshot/libopenshot-0.2.7.ebuild
+++ b/media-libs/libopenshot/libopenshot-0.2.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-single-r1 toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/OpenShot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0/21"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc examples +imagemagick +opencv +python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -38,21 +38,12 @@ BDEPEND="doc? ( app-doc/doxygen )
dev-libs/unittest++
)"
-check_compiler() {
- if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
- eerror "${P} requires a compiler with OpenMP support. Your current"
- eerror "compiler does not support it. If you use gcc, you can"
- eerror "re-emerge it with the 'openmp' use flag enabled."
- die "The current compiler does not support OpenMP"
- fi
-}
-
pkg_pretend() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- check_compiler
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
use python && python-single-r1_pkg_setup
}