summaryrefslogtreecommitdiff
path: root/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild')
-rw-r--r--media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
new file mode 100644
index 000000000000..317958e4f21a
--- /dev/null
+++ b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="Library for asynchronous OpenGL recording with audio"
+HOMEPAGE="https://github.com/Benau/libopenglrecorder"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openh264 sound vpx"
+
+RDEPEND="media-libs/libjpeg-turbo[${MULTILIB_USEDEP}]
+ openh264? ( media-libs/openh264[${MULTILIB_USEDEP}] )
+ sound? (
+ media-libs/libvorbis[${MULTILIB_USEDEP}]
+ media-sound/pulseaudio[${MULTILIB_USEDEP}]
+ )
+ vpx? ( media-libs/libvpx:0=[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(
+ CHANGELOG.md
+ README.md
+ USAGE.md
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PULSE_WO_DL=ON
+ -DBUILD_SHARED_LIBS=ON
+ -DSTATIC_RUNTIME_LIBS=OFF
+ -DBUILD_WITH_H264=$(usex openh264)
+ -DBUILD_RECORDER_WITH_SOUND=$(usex sound)
+ -DBUILD_WITH_VPX=$(usex vpx)
+ )
+ cmake-utils_src_configure
+}