summaryrefslogtreecommitdiff
path: root/media-libs/libmpris2client/libmpris2client-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libmpris2client/libmpris2client-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libmpris2client/libmpris2client-0.1.0.ebuild')
-rw-r--r--media-libs/libmpris2client/libmpris2client-0.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libmpris2client/libmpris2client-0.1.0.ebuild b/media-libs/libmpris2client/libmpris2client-0.1.0.ebuild
new file mode 100644
index 000000000000..07967c18380b
--- /dev/null
+++ b/media-libs/libmpris2client/libmpris2client-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="An library to control MPRIS2 compatible players"
+HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
+SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README TODO"
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }