summaryrefslogtreecommitdiff
path: root/media-libs/liblo/liblo-0.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 11:39:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 11:39:43 +0000
commitfac3cfaabc3c46bf5cb7a2492197925c7c557b42 (patch)
tree2f349d3ce8993d9ac6d35958db8b9d82b8fe40cc /media-libs/liblo/liblo-0.32.ebuild
parentb24782302154e447b59c3f719970f951cd15cd38 (diff)
gentoo auto-resync : 19:02:2024 - 11:39:43
Diffstat (limited to 'media-libs/liblo/liblo-0.32.ebuild')
-rw-r--r--media-libs/liblo/liblo-0.32.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/liblo/liblo-0.32.ebuild b/media-libs/liblo/liblo-0.32.ebuild
new file mode 100644
index 000000000000..9171839108b5
--- /dev/null
+++ b/media-libs/liblo/liblo-0.32.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="https://sourceforge.net/projects/liblo/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~loong ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-text/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.31-werror.patch
+)
+
+src_prepare() {
+ default
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ local myeconfargs=(
+ --enable-threads
+ --disable-network-tests
+ $(use_enable test tests)
+ # See README.md note wrt ipv6. Disabled by default upstream
+ # because can break Pd and SuperCollider.
+ $(use_enable ipv6)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}