summaryrefslogtreecommitdiff
path: root/media-libs/libilbc/libilbc-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libilbc/libilbc-2.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libilbc/libilbc-2.0.2.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-2.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libilbc/libilbc-2.0.2.ebuild b/media-libs/libilbc/libilbc-2.0.2.ebuild
new file mode 100644
index 000000000000..65a7182ed61f
--- /dev/null
+++ b/media-libs/libilbc/libilbc-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == 9999 ]] ; then
+ SCM="autotools git-2"
+ EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+fi
+
+inherit eutils multilib ${SCM} autotools-multilib
+
+DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
+HOMEPAGE="https://github.com/TimothyGu/libilbc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.2-ppc_ppc64.patch
+ [[ ${PV} == *9999 ]] && eautoreconf
+ autotools-multilib_src_prepare
+}