summaryrefslogtreecommitdiff
path: root/media-libs/libilbc/libilbc-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-libs/libilbc/libilbc-2.0.2.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-libs/libilbc/libilbc-2.0.2.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-2.0.2.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/media-libs/libilbc/libilbc-2.0.2.ebuild b/media-libs/libilbc/libilbc-2.0.2.ebuild
index 40eb6ee13b72..d01615a69b31 100644
--- a/media-libs/libilbc/libilbc-2.0.2.ebuild
+++ b/media-libs/libilbc/libilbc-2.0.2.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-if [[ ${PV} == 9999 ]] ; then
- SCM="autotools git-2"
+inherit multilib-minimal
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
EGIT_REPO_URI="https://github.com/TimothyGu/${PN}"
- SRC_URI=""
else
SRC_URI="https://github.com/TimothyGu/${PN}/releases/download/v${PV}/${P}.tar.bz2"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~sparc x86"
fi
-inherit eutils multilib ${SCM} autotools-multilib
-
DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
HOMEPAGE="https://github.com/TimothyGu/libilbc"
@@ -21,8 +20,21 @@ LICENSE="BSD"
SLOT="0"
IUSE="static-libs"
+PATCHES=( "${FILESDIR}"/${PN}-2.0.2-ppc_ppc64_sparc.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.2-ppc_ppc64_sparc.patch
+ default
[[ ${PV} == *9999 ]] && eautoreconf
- autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}