summaryrefslogtreecommitdiff
path: root/media-libs/libilbc/libilbc-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libilbc/libilbc-1.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libilbc/libilbc-1.1.1.ebuild')
-rw-r--r--media-libs/libilbc/libilbc-1.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/libilbc/libilbc-1.1.1.ebuild b/media-libs/libilbc/libilbc-1.1.1.ebuild
new file mode 100644
index 000000000000..69c70d5fafb1
--- /dev/null
+++ b/media-libs/libilbc/libilbc-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+if [[ ${PV} == 9999 ]] ; then
+ SCM="autotools git-2"
+ EGIT_REPO_URI="https://github.com/lu-zero/${PN}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+inherit eutils multilib ${SCM}
+
+DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
+HOMEPAGE="https://github.com/lu-zero/libilbc https://github.com/TimothyGu/libilbc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}