summaryrefslogtreecommitdiff
path: root/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'media-libs/libhdhomerun/libhdhomerun-20200521.ebuild')
-rw-r--r--media-libs/libhdhomerun/libhdhomerun-20200521.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
new file mode 100644
index 000000000000..953fe13103b2
--- /dev/null
+++ b/media-libs/libhdhomerun/libhdhomerun-20200521.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SiliconDust HDHomeRun Utilties"
+HOMEPAGE="https://www.silicondust.com/support/linux/"
+SRC_URI="https://download.silicondust.com/hdhomerun/${PN}_${PV}.tgz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/20190621-use_shared_library.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ #Remove forced optimization from Makefile
+ sed -i 's:-O2::' Makefile || die "Was the Makefile changed?"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) STRIP=:
+}
+
+src_install() {
+ dobin hdhomerun_config
+ dolib.so libhdhomerun.so
+
+ insinto /usr/include/hdhomerun
+ doins *.h
+}