summaryrefslogtreecommitdiff
path: root/media-libs/libfishsound/libfishsound-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /media-libs/libfishsound/libfishsound-1.0.0.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'media-libs/libfishsound/libfishsound-1.0.0.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
index e67184a6f17c..d5fe387728b8 100644
--- a/media-libs/libfishsound/libfishsound-1.0.0.ebuild
+++ b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=7
-DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
-HOMEPAGE="http://www.xiph.org/fishsound/"
-SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
+HOMEPAGE="https://www.xiph.org/fishsound/"
+SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="flac speex"
-RDEPEND="media-libs/libvorbis
+RDEPEND="
media-libs/libogg
+ media-libs/libvorbis
flac? ( media-libs/flac )
speex? ( media-libs/speex )"
DEPEND="${RDEPEND}
@@ -23,8 +23,10 @@ DEPEND="${RDEPEND}
# bug #395153
RESTRICT="test"
+PATCHES=( "${FILESDIR}"/${P}-pc.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-pc.patch
+ default
sed -i \
-e 's:doxygen:doxygen-dummy:' \
configure || die
@@ -42,6 +44,6 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" \
- docdir="${D}/usr/share/doc/${PF}" install || die
+ docdir="${D}/usr/share/doc/${PF}" install
dodoc AUTHORS ChangeLog README
}