summaryrefslogtreecommitdiff
path: root/media-libs/libebur128/libebur128-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libebur128/libebur128-1.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libebur128/libebur128-1.2.0-r1.ebuild')
-rw-r--r--media-libs/libebur128/libebur128-1.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libebur128/libebur128-1.2.0-r1.ebuild b/media-libs/libebur128/libebur128-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..8ddaa34fcd8d
--- /dev/null
+++ b/media-libs/libebur128/libebur128-1.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library implementing the EBU R128 loudness standard"
+HOMEPAGE="https://github.com/jiixyj/libebur128"
+SRC_URI="https://github.com/jiixyj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://tech.ebu.ch/files/live/sites/tech/files/shared/testmaterial/ebu-loudness-test-setv05.zip )"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( app-arch/unzip
+ media-libs/libsndfile[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cd "${WORKDIR}"
+ "${BUILD_DIR}"/r128-test-library | tee test-results
+ grep -c "^FAILED" test-results > /dev/null \
+ && die "At least one test failed"
+}