summaryrefslogtreecommitdiff
path: root/media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild')
-rw-r--r--media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild b/media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f0fa2c6f9dde
--- /dev/null
+++ b/media-libs/libdvbcsa/libdvbcsa-1.1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free implementation of the DVB Common Scrambling Algorithm - DVB/CSA"
+HOMEPAGE="https://www.videolan.org/developers/libdvbcsa.html"
+SRC_URI="https://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse2 debug"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable debug)
+ )
+
+ # Enabling MMX makes the configure script ignore SSE2.
+ if use cpu_flags_x86_sse2; then
+ myeconfargs+=(
+ --disable-mmx
+ --enable-sse2
+ )
+ else
+ myeconfargs+=(
+ $(use_enable cpu_flags_x86_mmx mmx)
+ --disable-sse2
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}