summaryrefslogtreecommitdiff
path: root/media-libs/libde265/libde265-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-libs/libde265/libde265-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-libs/libde265/libde265-9999.ebuild')
-rw-r--r--media-libs/libde265/libde265-9999.ebuild67
1 files changed, 47 insertions, 20 deletions
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
index 7f4f73fb81e2..1b591f16c364 100644
--- a/media-libs/libde265/libde265-9999.ebuild
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="Open h.265 video codec implementation"
@@ -20,18 +20,31 @@ HOMEPAGE="https://github.com/strukturag/libde265"
LICENSE="GPL-3"
SLOT="0"
-IUSE="cpu_flags_x86_sse debug qt5 static-libs"
-
-DEPEND="
- media-libs/libsdl[${MULTILIB_USEDEP}]
- media-video/ffmpeg:=[${MULTILIB_USEDEP}]
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
+IUSE="enc265 dec265 sdl tools debug static-libs cpu_flags_x86_sse4_1 cpu_flags_arm_neon cpu_flags_arm_thumb"
+# IUSE+=" sherlock265" # Require libvideogfx or libswscale
+
+RDEPEND="
+ dec265? (
+ sdl? ( media-libs/libsdl )
)
"
-RDEPEND="${DEPEND}"
+# Sherlock265 require libvideogfx or libswscale
+#RDEPEND+="
+# sherlock265? (
+# media-libs/libsdl
+# dev-qt/qtcore:5
+# dev-qt/qtgui:5
+# dev-qt/qtwidgets:5
+# media-libs/libswscale
+# )
+#"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dec265? ( virtual/pkgconfig )"
+
+# Sherlock265 require libvideogfx or libswscale
+#BDEPEND+=" sherlock265? ( virtual/pkgconfig )"
src_prepare() {
default
@@ -44,26 +57,40 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
- $(use_enable cpu_flags_x86_sse sse)
+ ax_cv_check_cflags___msse4_1=$(usex cpu_flags_x86_sse4_1)
+ ax_cv_check_cflags___mfpu_neon=$(usex cpu_flags_arm_neon)
+ $(use_enable cpu_flags_arm_thumb thumb)
$(use_enable static-libs static)
$(use_enable debug log-info)
$(use_enable debug log-debug)
$(use_enable debug log-trace)
+ $(multilib_native_use_enable enc265 encoder)
+ $(multilib_native_use_enable dec265)
--enable-log-error
)
- if ! multilib_is_native_abi; then
- myeconfargs+=( --disable-dec265 --disable-sherlock265 )
- else
- myeconfargs+=(
- $(use_enable qt5 dec265)
- $(use_enable qt5 sherlock265)
- )
- fi
+ # myeconfargs+=( $(multilib_native_use_enable sherlock265) ) # Require libvideogfx or libswscale
+ myeconfargs+=( --disable-sherlock265 )
econf "${myeconfargs[@]}"
}
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ # Remove useless, unready and test tools (Why package ever tried to install them??)
+ rm -f "${ED}/usr/bin/"{tests,gen-enc-table,yuv-distortion} || die
+ if ! use tools; then
+ rm -f "${ED}/usr/bin/"{bjoentegaard,block-rate-estim,rd-curves} || die
+ rm -f "${ED}/usr/bin/acceleration_speed" || die
+ fi
+ else
+ # Remove all non-native binary tools
+ rm -f "${ED}/usr/bin/"* || die
+ fi
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then