summaryrefslogtreecommitdiff
path: root/media-libs/libcuefile/libcuefile-477-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libcuefile/libcuefile-477-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libcuefile/libcuefile-477-r1.ebuild')
-rw-r--r--media-libs/libcuefile/libcuefile-477-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/libcuefile/libcuefile-477-r1.ebuild b/media-libs/libcuefile/libcuefile-477-r1.ebuild
new file mode 100644
index 000000000000..645c6d45c62c
--- /dev/null
+++ b/media-libs/libcuefile/libcuefile-477-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-multilib
+
+# svn export http://svn.musepack.net/libcuefile/trunk libcuefile-${PV}
+# tar -cJf libcuefile-${PV}.tar.xz libcuefile-${PV}
+
+DESCRIPTION="Cue File library from Musepack"
+HOMEPAGE="http://www.musepack.net/"
+SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r2
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+src_install() {
+ cmake-multilib_src_install
+ insinto /usr/include
+ doins -r include/cuetools
+}