summaryrefslogtreecommitdiff
path: root/media-libs/libcaca/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libcaca/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libcaca/files')
-rw-r--r--media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch61
-rw-r--r--media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch14
2 files changed, 75 insertions, 0 deletions
diff --git a/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch b/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch
new file mode 100644
index 000000000000..f9ff8090c215
--- /dev/null
+++ b/media-libs/libcaca/files/libcaca-0.99_beta18-fix-tests.patch
@@ -0,0 +1,61 @@
+--- test/Makefile.am
++++ test/Makefile.am
+@@ -1,3 +1,5 @@
++AM_TESTS_ENVIRONMENT = \
++ top_srcdir="$(top_srcdir)"
+
+ AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/caca -I../caca
+
+--- test/check-copyright
++++ test/check-copyright
+@@ -3,10 +3,11 @@
+ #
+ # Check that the copyright information is valid
+ #
++echo "top srcdir: ${top_srcdir:=..}"
+ nfails=0
+ nfiles=0
+ for dir in $(make -s echo-dirs -C ..); do
+- if [ ! -d "../$dir" ]; then continue; fi
++ if [ ! -d "$top_srcdir/$dir" ]; then continue; fi
+ for x in $(make -s echo-sources -C ../$dir); do
+ case "$x" in
+ *.c|*.cpp|*.h|*.m|*.php|*.cs|*.java|.py|.pl)
+@@ -14,7 +15,7 @@
+ *)
+ continue ;;
+ esac
+- if ! grep 'Copyright *([cC])' "../$dir/$x" >/dev/null 2>&1; then
++ if ! grep 'Copyright *([cC])' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x lacks proper copyright information"
+ nfails=$(($nfails + 1))
+ elif [ -d ../.git ]; then
+--- test/check-source
++++ test/check-source
+@@ -3,6 +3,7 @@
+ #
+ # Check that we have no tabs or trailing spaces in the source code
+ #
++echo "top srcdir: ${top_srcdir:=..}"
+ nfails=0
+ nfiles=0
+ nlines=0
+@@ -12,15 +13,15 @@
+ case "$x" in
+ *.c|*.cpp|*.h|*.m|*.php|*.cs|*.java|*.py|*.pl)
+ nfiles=$(($nfiles + 1));
+- nlines=$(($nlines + `grep -c . "../$dir/$x"`)) ;;
++ nlines=$(($nlines + `grep -c . "$top_srcdir/$dir/$x"`)) ;;
+ *)
+ continue ;;
+ esac
+- if grep '[[:space:]]$' "../$dir/$x" >/dev/null 2>&1; then
++ if grep '[[:space:]]$' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x contains trailing spaces"
+ nfails=$(($nfails + 1))
+ fi
+- if grep ' ' "../$dir/$x" >/dev/null 2>&1; then
++ if grep ' ' "$top_srcdir/$dir/$x" >/dev/null 2>&1; then
+ echo "error: $dir/$x contains tabs"
+ nfails=$(($nfails + 1))
+ fi
diff --git a/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch b/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch
new file mode 100644
index 000000000000..060822e6dcc7
--- /dev/null
+++ b/media-libs/libcaca/files/libcaca-0.99_beta18-latex_hacks.patch
@@ -0,0 +1,14 @@
+Hack it a bit differently so that it works with texlive 2013, see http://bugs.gentoo.org/480862
+Turns out this patch is required also for texlive 2012, see http://bugs.gentoo.org/517474
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -29,7 +29,7 @@ if BUILD_DOCUMENTATION
+ if USE_LATEX
+ rm -f latex/libcaca.tex latex/libcaca.pdf
+ mv latex/refman.tex latex/libcaca.tex
+- sed 's/setlength{/renewcommand{/' latex/libcaca.tex \
++ sed 's/\\setlength{/%\0/' latex/libcaca.tex \
+ | sed 's/.*usepackage.*times.*//' > latex/refman.tex
+ cd latex && $(MAKE) $(AM_CFLAGS) refman.pdf || (cat refman.log; exit 1)
+ mv latex/refman.pdf latex/libcaca.pdf