summaryrefslogtreecommitdiff
path: root/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild')
-rw-r--r--media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild b/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
new file mode 100644
index 000000000000..06b2c20ea9c1
--- /dev/null
+++ b/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="implementation of SMPTE and the MXF Interop Sound & Picture Track File format"
+HOMEPAGE="http://carlh.net/asdcplib"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ dev-util/waf
+ virtual/pkgconfig
+ ${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.1-no-ldconfig.patch
+ "${FILESDIR}"/${PN}-0.1.2-respect-cxxflags.patch)
+
+src_prepare() {
+ rm -r waf aclocal.m4 m4 configure{,.ac} Makefile.{am,in} || die
+ export WAF_BINARY=${EROOT}usr/bin/waf
+
+ default
+}