summaryrefslogtreecommitdiff
path: root/media-libs/libaom/libaom-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /media-libs/libaom/libaom-9999.ebuild
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'media-libs/libaom/libaom-9999.ebuild')
-rw-r--r--media-libs/libaom/libaom-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 358a43197c20..d2f98922596a 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
-inherit cmake-multilib
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- SRC_URI="https://dev.gentoo.org/~whissi/dist/libaom/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
+ S="${WORKDIR}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
@@ -19,7 +21,7 @@ HOMEPAGE="https://aomedia.org"
LICENSE="BSD-2"
SLOT="0/3"
-IUSE="doc examples"
+IUSE="doc +examples"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
IUSE="${IUSE} cpu_flags_arm_neon"
@@ -29,7 +31,8 @@ REQUIRED_USE="
cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
"
-BDEPEND="abi_x86_32? ( dev-lang/yasm )
+BDEPEND="${PYTHON_DEPS}
+ abi_x86_32? ( dev-lang/yasm )
abi_x86_64? ( dev-lang/yasm )
abi_x86_x32? ( dev-lang/yasm )
x86-fbsd? ( dev-lang/yasm )
@@ -42,6 +45,7 @@ DOCS=( PATENTS )
multilib_src_configure() {
local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
-DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
-DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
-DENABLE_NASM=OFF
@@ -49,6 +53,9 @@ multilib_src_configure() {
-DENABLE_TOOLS=ON
-DENABLE_WERROR=OFF
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
# neon support is assumed to be always enabled on arm64
-DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
# ENABLE_DSPR2 / ENABLE_MSA for mips
@@ -62,6 +69,7 @@ multilib_src_configure() {
-DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
-DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
)
+
cmake_src_configure
}
@@ -69,6 +77,7 @@ multilib_src_install() {
if multilib_is_native_abi && use doc ; then
local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
+
cmake_src_install
}