summaryrefslogtreecommitdiff
path: root/media-libs/libaom/libaom-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-libs/libaom/libaom-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-libs/libaom/libaom-9999.ebuild')
-rw-r--r--media-libs/libaom/libaom-9999.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index a437118de10a..358a43197c20 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,14 +10,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
- if [[ ${PV} == *pre* ]]; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- S="${WORKDIR}/${PN}"
- else
- # SRC_URI="https://aomedia.googlesource.com/aom/+archive/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="mirror://gentoo/${P}.tar.gz"
- S="${WORKDIR}"
- fi
+ SRC_URI="https://dev.gentoo.org/~whissi/dist/libaom/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
@@ -25,7 +18,7 @@ DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
HOMEPAGE="https://aomedia.org"
LICENSE="BSD-2"
-SLOT="0/2"
+SLOT="0/3"
IUSE="doc examples"
IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
@@ -56,7 +49,8 @@ multilib_src_configure() {
-DENABLE_TOOLS=ON
-DENABLE_WERROR=OFF
- -DENABLE_NEON=$(usex cpu_flags_arm_neon ON OFF)
+ # neon support is assumed to be always enabled on arm64
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
# ENABLE_DSPR2 / ENABLE_MSA for mips
-DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
-DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)