summaryrefslogtreecommitdiff
path: root/media-libs/lcms/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/lcms/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/lcms/files')
-rw-r--r--media-libs/lcms/files/lcms-2.13-grayscale-regression.patch38
-rw-r--r--media-libs/lcms/files/lcms-2.13.1-fix-configure-bashisms.patch22
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/lcms/files/lcms-2.13-grayscale-regression.patch b/media-libs/lcms/files/lcms-2.13-grayscale-regression.patch
new file mode 100644
index 000000000000..d1ce0483ee6f
--- /dev/null
+++ b/media-libs/lcms/files/lcms-2.13-grayscale-regression.patch
@@ -0,0 +1,38 @@
+https://github.com/mm2/Little-CMS/commit/fdbfb7694f9d7048d53674b79ddfc38068bfdaf7
+https://bugs.gentoo.org/832520
+
+From: Marti Maria <marti.maria@littlecms.com>
+Date: Sun, 30 Jan 2022 16:56:48 +0100
+Subject: [PATCH] Fix for optimisation error on grayscale
+
+Thanks to Aaron Boxer for reporting this issue
+--- a/src/cmsintrp.c
++++ b/src/cmsintrp.c
+@@ -278,10 +278,10 @@ void Eval1Input(CMSREGISTER const cmsUInt16Number Input[],
+ // if last value...
+ if (Input[0] == 0xffff || p16->Domain[0] == 0) {
+
+- cmsUInt16Number y0 = LutTable[p16->Domain[0]];
+-
++ cmsUInt32Number y0 = p16->Domain[0] * p16->opta[0];
++
+ for (OutChan = 0; OutChan < p16->nOutputs; OutChan++) {
+- Output[OutChan] = y0;
++ Output[OutChan] = LutTable[y0 + OutChan];
+ }
+ }
+ else
+@@ -324,10 +324,10 @@ void Eval1InputFloat(const cmsFloat32Number Value[],
+ // if last value...
+ if (val2 == 1.0 || p->Domain[0] == 0) {
+
+- y0 = LutTable[p->Domain[0]];
++ cmsUInt32Number start = p->Domain[0] * p->opta[0];
+
+ for (OutChan = 0; OutChan < p->nOutputs; OutChan++) {
+- Output[OutChan] = y0;
++ Output[OutChan] = LutTable[start + OutChan];
+ }
+ }
+ else
+
diff --git a/media-libs/lcms/files/lcms-2.13.1-fix-configure-bashisms.patch b/media-libs/lcms/files/lcms-2.13.1-fix-configure-bashisms.patch
new file mode 100644
index 000000000000..41e12fdf1f4e
--- /dev/null
+++ b/media-libs/lcms/files/lcms-2.13.1-fix-configure-bashisms.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/832733
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@
+ AC_PROG_LIBTOOL
+ AC_SUBST(LIBTOOL_DEPS)
+
+-LIB_PLUGINS = ''
++LIB_PLUGINS=''
+
+ # Add configure option --enable-maintainer-mode which enables dependency
+ # checking and generation useful to package maintainers. This is made an
+@@ -149,7 +149,7 @@
+ [
+ with_fastfloat='no'
+ ])
+-if test "$with_fastfloat" == "yes"
++if test "$with_fastfloat" = "yes"
+ then
+ LIB_PLUGINS="$LIB_PLUGINS -llcms2_fast_float"
+ fi
+