summaryrefslogtreecommitdiff
path: root/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/lastfmlib/lastfmlib-0.4.0.ebuild')
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
new file mode 100644
index 000000000000..ed124b016c70
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog
+ find "${D}"/usr -name '*.la' -delete
+}