summaryrefslogtreecommitdiff
path: root/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild')
-rw-r--r--media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
index b1e25014dafb..f6949b5e887e 100644
--- a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
+++ b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils
+inherit autotools
DESCRIPTION="JBIG2 Encoder and libs"
HOMEPAGE="https://github.com/agl/jbig2enc"
@@ -13,19 +12,29 @@ SRC_URI="https://github.com/agl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86 ~ppc-macos"
-
-IUSE="gif jpeg png static-libs tiff webp"
+IUSE="gif jpeg png tiff webp"
RDEPEND="media-libs/leptonica[gif?,jpeg?,png?,tiff?,webp?]"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-leptonica-1.70.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-leptonica-1.70.patch"
+)
src_prepare() {
+ default
+
# remove -Werror
sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac || die 'sed on configure.ac failed'
# prevent static linking and QA notice about insecure RUNPATHs
sed -i -e '/jbig2_LDFLAGS/d' src/Makefile.am || die 'sed on src/Makefile.am failed'
- autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -name '*.a' -delete || die
}