summaryrefslogtreecommitdiff
path: root/media-libs/jasper/jasper-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /media-libs/jasper/jasper-9999.ebuild
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'media-libs/jasper/jasper-9999.ebuild')
-rw-r--r--media-libs/jasper/jasper-9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/media-libs/jasper/jasper-9999.ebuild b/media-libs/jasper/jasper-9999.ebuild
index 39254dafd4cc..ed20cb057f96 100644
--- a/media-libs/jasper/jasper-9999.ebuild
+++ b/media-libs/jasper/jasper-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=6
inherit cmake-multilib
@@ -12,17 +12,17 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
else
+ inherit vcs-snapshot
SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
- S="${WORKDIR}/${PN}-version-${PV}"
fi
# We limit memory usage to 128 MiB by default, specified in bytes
: ${JASPER_MEM_LIMIT:=134217728}
LICENSE="JasPer2.0"
-SLOT="0/4"
-IUSE="doc jpeg opengl test"
+SLOT="0"
+IUSE="doc jpeg opengl"
RDEPEND="
jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
@@ -33,10 +33,8 @@ RDEPEND="
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXmu[${MULTILIB_USEDEP}]
)"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
multilib_src_configure() {
local mycmakeargs=(
@@ -60,8 +58,6 @@ multilib_src_configure() {
# Doxygen
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
-
- -DJAS_ENABLE_PROGRAMS=$(usex test)
)
cmake-utils_src_configure
}