summaryrefslogtreecommitdiff
path: root/media-libs/jasper/jasper-2.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-libs/jasper/jasper-2.0.14.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-libs/jasper/jasper-2.0.14.ebuild')
-rw-r--r--media-libs/jasper/jasper-2.0.14.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/media-libs/jasper/jasper-2.0.14.ebuild b/media-libs/jasper/jasper-2.0.14.ebuild
deleted file mode 100644
index 1a72b593b949..000000000000
--- a/media-libs/jasper/jasper-2.0.14.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
-HOMEPAGE="https://www.ece.uvic.ca/~mdadams/jasper/"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-
-# We limit memory usage to 128 MiB by default, specified in bytes
-: ${JASPER_MEM_LIMIT:=134217728}
-
-LICENSE="JasPer2.0"
-SLOT="0/4"
-IUSE="doc jpeg opengl test"
-
-RDEPEND="
- jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
- opengl? (
- >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
- >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
- virtual/glu[${MULTILIB_USEDEP}]
- x11-libs/libXi[${MULTILIB_USEDEP}]
- x11-libs/libXmu[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.0.14-fix-test-suite.patch )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DALLOW_IN_SOURCE_BUILD=OFF
- -DBASH_PROGRAM="${EPREFIX}"/bin/bash
- -DJAS_ENABLE_ASAN=OFF
- -DJAS_ENABLE_LSAN=OFF
- -DJAS_ENABLE_MSAN=OFF
- -DJAS_ENABLE_SHARED=ON
- -DJAS_ENABLE_STRICT=ON
- -DJAS_ENABLE_USAN=OFF
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
-
- # JPEG
- -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
- -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
-
- # OpenGL
- -DJAS_ENABLE_OPENGL=$(usex opengl)
- -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
-
- # Doxygen
- -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
-
- #-DJAS_ENABLE_PROGRAMS=$(usex test)
- )
- cmake-utils_src_configure
-}