summaryrefslogtreecommitdiff
path: root/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch')
-rw-r--r--media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch b/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch
new file mode 100644
index 000000000000..9af83c67c6f6
--- /dev/null
+++ b/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch
@@ -0,0 +1,28 @@
+Disable tests which will require LIBJPEG when Jasper was
+built without LIBJPEG.
+
+Bug: https://bugs.gentoo.org/629898
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -393,12 +393,14 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/test/bin/wrapper.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper" @ONLY)
+
+ if (BASH_PROGRAM)
+- add_test(run_test_1
+- "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+- "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_1")
+- add_test(run_test_2
+- "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+- "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_2")
++ if (JAS_ENABLE_LIBJPEG)
++ add_test(run_test_1
++ "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
++ "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_1")
++ add_test(run_test_2
++ "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
++ "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_2")
++ endif()
+ add_test(run_test_3
+ "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+ "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_3")