summaryrefslogtreecommitdiff
path: root/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 21:11:24 +0000
commitd479c9c5c724c7b1300a98e44975f31f4f2e51dd (patch)
treec2f5550bfe03e1b3f19014e1576dcf50e6bd818c /media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
parentee8ad1509f726e8fa598472117e5bbffd241ebab (diff)
gentoo auto-resync : 06:12:2022 - 21:11:24
Diffstat (limited to 'media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild')
-rw-r--r--media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild47
1 files changed, 43 insertions, 4 deletions
diff --git a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild b/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
index 5e9ab6853a42..a42d8290d2f3 100644
--- a/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
+++ b/media-libs/intel-mediasdk/intel-mediasdk-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake
+inherit cmake optfeature
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/Intel-Media-SDK/MediaSDK"}
@@ -14,7 +14,7 @@ if [[ ${PV} == *9999 ]] ; then
fi
DESCRIPTION="Intel Media SDK"
-HOMEPAGE="http://mediasdk.intel.com"
+HOMEPAGE="https://github.com/Intel-Media-SDK/MediaSDK"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
else
@@ -26,18 +26,57 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="dri test +tools wayland X"
+# Test not working at the moment
+#RESTRICT="!test? ( test )"
+RESTRICT="test"
+# # Most of these flags only have an effect on the tools
+REQUIRED_USE="
+ dri? ( X )
+ wayland? ( tools )
+ X? ( tools )
+"
+
# x11-libs/libdrm[video_cards_intel] for intel_bufmgr.h in samples
# bug #805224
DEPEND="
+ x11-libs/libpciaccess
>=media-libs/libva-intel-media-driver-${PV}
+ media-libs/libva[X?,wayland?]
x11-libs/libdrm[video_cards_intel]
+ wayland? (
+ dev-libs/wayland
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
+ # OpenCL only has an effect if we build kernels
-DENABLE_OPENCL=OFF
+ -DBUILD_TUTORIALS=OFF
+ # Need to package the cm-compiler to build kernels, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_RUNTIME=ON
+ -DBUILD_DISPATCHER=ON
+ -DBUILD_TOOLS="$(usex tools)"
+ # Cannot build tools without samples
+ -DBUILD_SAMPLES="$(usex tools)"
+ -DBUILD_TESTS="$(usex test)"
+ -DENABLE_X11="$(usex X)"
+ -DENABLE_X11_DRI3="$(usex dri)"
+ -DENABLE_WAYLAND="$(usex wayland)"
)
cmake_src_configure
}
+
+pkg_postinst() {
+ optfeature "Intel GPUs newer then, and including, Intel Xe" media-libs/oneVPL-intel-gpu
+}