summaryrefslogtreecommitdiff
path: root/media-libs/ilmbase/ilmbase-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /media-libs/ilmbase/ilmbase-2.3.0.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'media-libs/ilmbase/ilmbase-2.3.0.ebuild')
-rw-r--r--media-libs/ilmbase/ilmbase-2.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/ilmbase/ilmbase-2.3.0.ebuild b/media-libs/ilmbase/ilmbase-2.3.0.ebuild
new file mode 100644
index 000000000000..318a31fd3910
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/openexr/openexr/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/24" # based on SONAME
+KEYWORDS="~amd64 -arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="static-libs"
+
+DEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfig.h )
+
+multilib_src_configure() {
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ export ac_cv_header_ucontext_h=no
+ fi
+
+ ECONF_SOURCE=${S} econf "$(use_enable static-libs static)"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides pkg-config files
+ find "${D}" -name '*.la' -delete || die
+}