summaryrefslogtreecommitdiff
path: root/media-libs/harfbuzz/harfbuzz-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /media-libs/harfbuzz/harfbuzz-9999.ebuild
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'media-libs/harfbuzz/harfbuzz-9999.ebuild')
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild48
1 files changed, 25 insertions, 23 deletions
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index c785260b6c40..3ba2f34c80be 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
+inherit flag-o-matic libtool ltprune multilib-minimal python-any-r1 xdg-utils
DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
-if [[ ${PV} != 9999 ]] ; then
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
+ inherit git-r3 autotools
+else
SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-else
- inherit git-r3 autotools
- #EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
fi
LICENSE="Old-MIT ISC icu"
@@ -41,10 +40,12 @@ DEPEND="${RDEPEND}
"
# eautoreconf requires gobject-introspection-common
# ragel needed if regenerating *.hh files from *.rl
-[[ ${PV} = 9999 ]] && DEPEND+="
- >=dev-libs/gobject-introspection-common-1.34
- dev-util/ragel
-"
+if [[ ${PV} = 9999 ]] ; then
+ DEPEND+="
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+ "
+fi
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -81,20 +82,21 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
# harfbuzz-gobject only used for instrospection, bug #535852
- econf \
- --without-coretext \
- --without-uniscribe \
- $(use_enable static-libs static) \
- $(multilib_native_use_with cairo) \
- $(use_with fontconfig) \
- $(use_with glib) \
- $(use_with introspection gobject) \
- $(use_with graphite graphite2) \
- $(use_with icu) \
- $(multilib_native_use_enable introspection) \
+ local myeconfargs=(
+ --without-coretext
+ --without-uniscribe
+ $(use_enable static-libs static)
+ $(multilib_native_use_with cairo)
+ $(use_with fontconfig)
+ $(use_with glib)
+ $(use_with introspection gobject)
+ $(use_with graphite graphite2)
+ $(use_with icu)
+ $(multilib_native_use_enable introspection)
$(use_with truetype freetype)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
if multilib_is_native_abi; then
ln -s "${S}"/docs/html docs/html || die