summaryrefslogtreecommitdiff
path: root/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 20:52:48 +0100
commit0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (patch)
treefca9d00e42cd967e466d66fd8d23d3bcee39cf75 /media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
parentc3d998909264b1ff687b9c65cae3046443e66f7e (diff)
gentoo auto-resync : 26:08:2022 - 20:52:47
Diffstat (limited to 'media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild')
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
new file mode 100644
index 000000000000..7caf66f5d784
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.20.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-r1
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P/gstreamer/gst}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+introspection test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.40.0:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-bad-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# Some tests are failing
+RESTRICT="test"
+
+S="${WORKDIR}"/${P/gstreamer/gst}
+
+src_configure() {
+ local emesonargs=(
+ -Ddoc=disabled # hotdoc not packaged
+ $(meson_feature introspection)
+ $(meson_feature test tests)
+ -Dbash-completion=disabled
+ -Dxptv=disabled
+ -Dpython=enabled
+ -Dvalidate=disabled
+ -Dexamples=disabled
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule bindings/python/gi/overrides/GES.py
+}