summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
commita90c84e720803f3d26c0ade8f1f1e405ca97502a (patch)
treef788ea0972d51c66823825021dd83427e1d466c4 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild
parent07c1e2fbaa2f7d2cad4c16a747cebcf7ae7a6724 (diff)
gentoo auto-resync : 14:01:2023 - 17:52:11
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild
new file mode 100644
index 000000000000..784791da0427
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-ugly"
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+inherit gstreamer-meson python-any-r1
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE=""
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}