summaryrefslogtreecommitdiff
path: root/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
commitd32022e7301aef2b3f52f6b7a3de81c6e03ffcaf (patch)
tree4e64fbab713348c061644255d893ff91f2d8b1e5 /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild
parent92f98ae772a60a2fa63efbda2f915da957a3b3b8 (diff)
gentoo auto-resync : 21:11:2022 - 01:03:25
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild
new file mode 100644
index 000000000000..72b44505b024
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-ugly"
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+inherit gstreamer-meson python-any-r1
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE=""
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}